Compile Error

Nima Palizban nima.palizban at
Mon Nov 3 02:10:36 EST 2014

I use fedora 20 , and I want to compile the source of the Pdigin, well I have just downloaded the   source code from SourceForge ""  and extract the compressed file, then I tried "./configure" it gave me some errors, so I tried to download and install all the dependencies by doing " yum-builddep pidgin-2.10.9-1.fc20.src.rpm " in my pidgin directory, and after that ./configure just worked for me and made a Makfilebut just after that when I try to compile the source code, by using make command in terminal, after some processing it gives me the following error: 
/usr/bin/ld: cannot find -lperlcollect2: error: ld returned 1 exit statusmake[6]: *** [blib/arch/auto/Purple/] Error 1make[6]: Leaving directory `/home/nima/Pidgin/pidgin-2.10.10/libpurple/plugins/perl/common'make[5]: *** [all-local] Error 2make[5]: Leaving directory `/home/nima/Pidgin/pidgin-2.10.10/libpurple/plugins/perl'make[4]: *** [all-recursive] Error 1make[4]: Leaving directory `/home/nima/Pidgin/pidgin-2.10.10/libpurple/plugins'make[3]: *** [all-recursive] Error 1make[3]: Leaving directory `/home/nima/Pidgin/pidgin-2.10.10/libpurple'make[2]: *** [all] Error 2make[2]: Leaving directory `/home/nima/Pidgin/pidgin-2.10.10/libpurple'make[1]: *** [all-recursive] Error 1make[1]: Leaving directory `/home/nima/Pidgin/pidgin-2.10.10'make: *** [all] Error 2

any help or guide would be appreciated in advancethnx

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Support mailing list