<div dir="ltr"><div class="gmail_extra"><div class="gmail_quote">On 9 February 2014 11:44, Mark Doliner <span dir="ltr"><<a href="mailto:mark@kingant.net" target="_blank">mark@kingant.net</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">

Thanks for sending this list! Your proposed renames mostly look good<br>
to me. And making those changes in 'default' sounds good.<br>
<div><br>
On Sat, Feb 8, 2014 at 1:14 PM, Elliott Sales de Andrade<br>
<<a href="mailto:qulogic@pidgin.im" target="_blank">qulogic@pidgin.im</a>> wrote:<br>
> On 8 February 2014 15:47, Ankit Vani <<a href="mailto:a@nevitus.org" target="_blank">a@nevitus.org</a>> wrote:<br>
</div><div>>> dbus-bindings.h:<br>
>>   'empty_to_null'           to 'purple_emptystr_to_null'<br>
>>   'null_to_empty'           to 'purple_null_to_emptystr'<br>
><br>
> I'm not sure if these DBus things are meant to be so public; they seem to be<br>
> there to help our DBus wrappers, no?<br>
<br>
</div>It does seem like they could be made internal. Or static. Fixing the<br>
namespace seems fine for now. Someone could investigate making them<br>
non-public later.<br>
<br></blockquote><div><br></div><div>I was also somewhat postulating that the GObject introspection would make this unnecessary?<br></div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">


>> server.h:<br>
<div>><br>
> This entire file needs to be re-namespaced, and purple_serv* is not the<br>
> right place for most of the functions, actually.<br>
<br>
</div>That's a bigger task, though. I think renaming them is fine for now,<br>
and is an improvement.<br>
<div><br>
>> theme-manager.h:<br>
>>   'PTFunc'                  to 'PurplePTFunc'<br>
><br>
> Doesn't the PT here stand for PurpleTheme?<br>
<br>
</div>It looks like it. I think this should be PurpleTFunc or<br>
PurpleThemeFunc. I like the latter.<br>
<div><br>
>> NAMESPACE CHANGES IN LIBGNT<br>
>> ===========================<br>
>><br>
>> gntentry.h:<br>
>>   'ENTRY_CHAR'             to 'GNT_ENTRY_CHAR'<br>
>><br>
>> gntutils.h:<br>
>>   'g_hash_table_duplicate' to 'gnt_hash_table_duplicate'<br>
>>   'GDupFunc'               to 'GntDupFunc'<br>
><br>
> This should perhaps spell out Duplicate in full.<br>
<br>
</div>I have no opinion.<br>
<br>
>> gtksourceiter.h:<br>
>> gtksourceundomanager.h:<br>
>> gtksourceview-marshal.h:<br>
<div>><br>
> You may want to hold off on GtkSourceUndoManager. IIRC, it was ported from<br>
> the real GTK+ widget so that we'd have something to use in GtkIMHtml, but<br>
> now that we've switched to GtkWebView, it may not be necessary. I haven't<br>
> really checked that Undo works correctly in the webview, though.<br>
<br>
</div>I tested undo in webview and it worked great for me. I removed all<br>
three of these files (and the .c files).<br>
<div><br></div></blockquote><div><br></div><div>I think the concern was adding/removing smileys. But I'm not sure we have that working yet, and I think undo could be done with WebKit-only stuff.<br></div><div> </div>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div>
>> gtkthemes.h:<br>
>>   'smiley_list'                                       to<br>
>> 'PidginSmileyList'<br>
>>   'smiley_theme'                                      to<br>
>> 'PidginSmileyTheme'<br>
><br>
> I wonder if these need to be public.<br>
<br>
</div>They are currently used outside of gtkthemes.h/.c, so it seems like<br>
the answer is yes.<br>
<br>
>> gtkwebview.h:<br>
>> gtkwebviewtoolbar.h:<br>
<div>><br>
> I think I looked into changing the namespace for GtkWebView and/or<br>
> GtkWhiteboard, and might still have the code somewhere, so give me a chance<br>
> to look for it.<br>
<br>
</div>Ankit: Or if it's faster for you to redo the renaming, don't feel<br>
obligated to wait for Elliott :-)<br>
</blockquote></div><br></div><div class="gmail_extra">I just found the change for GtkWebView. It needs a rebase, but I should be able to push it out today.<br clear="all"></div><div class="gmail_extra"><br>-- <br>Elliott aka QuLogic<br>
Pidgin developer
</div></div>