pidgin 2.10.6 on Ubuntu 12.10: cannot connect behind a HTTP Proxy to gmail account

Marcello Magaldi magowiz at gmail.com
Thu Mar 21 05:28:49 EDT 2013


Hi all,
I'm trying to configure my gmail account to make it work behind an HTTP
proxy, I set IP, port, proxy username and proxy password correctly into
proxy tab of mine account, pidgin tries to connect, and after a while
(after line
that contains  xmlns:stream='http://etherx.jabber.org/streams into log) I
got a disconnection.
The log follows , obviously I replaced my usernames with (*****) and proxy
IP with (xxx) :



(10:14:42) account: Connecting to account **********@gmail.com/.
(10:14:42) connection: Connecting. gc = 0x7f2476513230
(10:14:42) dnssrv: querying SRV record for gmail.com: _xmpp-client._
tcp.gmail.com
(10:14:47) util: Writing file accounts.xml to directory
/home/*******/.purple
(10:14:47) util: Writing file /home/*********/.purple/accounts.xml
(10:15:02) dnssrv: res_query returned an error
(10:15:02) dnsquery: Performing DNS lookup for xx.xxx.x.xxx
(10:15:02) dnsquery: IP resolved for xx.xxx.x.xxx
(10:15:02) proxy: Attempting connection to xx.xxx.x.xxx
(10:15:02) proxy: Connecting to gmail.com:5222 via xx.xxx.x.xxx:8080 using
HTTP
(10:15:02) proxy: Connection in progress
(10:15:02) proxy: Connected to gmail.com:5222.
(10:15:02) proxy: Using CONNECT tunneling for gmail.com:5222
(10:15:02) proxy: HTTP proxy connection established
(10:15:02) proxy: Connected to gmail.com:5222.
(10:15:02) jabber: Sending (******@gmail.com): <?xml version='1.0' ?>
(10:15:02) jabber: Sending (******@gmail.com): <stream:stream to='gmail.com'
xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams'
version='1.0'>
(10:15:21) autorecon: do_signon called
(10:15:21) autorecon: calling purple_account_connect
(10:15:21) account: Connecting to account ********@gmail.com/.
(10:15:21) autorecon: done calling purple_account_connect
(10:18:11) connection: Connection error on 0x7f2476513230 (reason: 0
description: the server closed connection)


Is there any possibility I can connect in this situation ? I also tried to
change proxy type but I didn't get connected.

Cheers

Marcello
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pidgin.im/pipermail/support/attachments/20130321/42af724c/attachment.html>


More information about the Support mailing list