Lost messages with MSN

Michael Secord gizmokid2005 at gmail.com
Wed Mar 14 14:05:43 EDT 2012



On 3/14/2012 1:55 PM Dave Warren <lists at hireahit.com> said unto 
support at pidgin.im:

> On 3/14/2012 7:16 AM, Michael Secord wrote:
>> I've noticed an issue where I'm not receiving all messages that are
>> being sent to me through MSN. I fired up the official client (LM) and
>> ran it alongside pidgin yesterday with the same account and watched
>> messages come in via LM but not in Pidgin with the debug window not
>> showing anything odd. I was able to capture a few minutes of net
>> traffic with Wireshark while this was happening.
>>
>> I've noticed that it doesn't matter if the person sending the messages
>> is using the official client or Pidgin, as the issue happens with
>> both. I only miss the messages if I'm using Pidgin, the official
>> client will catch everything.
>>
>> Anyone have any ideas or anything else I should try to capture, etc to
>> help determine the cause of this?
>
> Any idea if you had multiple clients connected when the problem was
> first observed?
>
> I haven't been able to figure out the pattern, but if I leave my iPhone
> and iPad (or multiple pidgin installations) connected to my MSN account,
> messages semi-randomly start going to the inactive client despite the
> fact that I haven't used it for hours or days.
>
> New messages tend to go to all connected clients, which is a good thing,
> but in the middle of a conversation I'll feel like the person I'm
> talking to is ignoring a question and later discover that they did
> answer and it wasn't delivered to pidgin.
>
> I've never tested to see if the official client behaves differently,
> I've always just assumed it's a quirk with how MSN determines the
> message destination since it happens to pidgin, Beejive and IM+.
>

I actually noticed the issue with Pidgin being the only connected 
client, but the issue persisted with or without another client connected.

I can't say whether or not this used to happen in previous versions of 
Pidgin since I used to use MSN so infrequently, but now that it's the 
_only_ method of IM at my workplace, it's much more prevalent.

The official client seems to catch all incoming messages just fine. I 
also noticed that sometimes it'll pick up the messages that I send from 
Pidgin, while other times it will not.

As a side-note, using the MSN protocol that is built into Bittlebee 
(http://bittlebee.org/) seems to work as expected thus far, though that 
only equates to a few hours today.

-Michael



More information about the Support mailing list