Bug when clicking on a http link with web browser closed

Daniel Atallah datallah at pidgin.im
Thu Oct 29 11:08:47 EDT 2009


On Thu, Oct 29, 2009 at 10:34,  <Matthieu.Rioteau at skf.com> wrote:
>
>> On Thu, Oct 29, 2009 at 07:14,  <Matthieu.Rioteau at skf.com> wrote:
>> >
>> > Hi everybody,
>> >
>> > Just have a strange behavior in Pidgin (never noticed that before 2.6.3
>> > release).
>> >
>> > When I click a http link in discussion windows AND that the web browser
>> > (Firefox) is closed, a Windows error message box appears telling "Window
>> > cannot find '[the_link]'. Make sure you typed the name correctly, and
>> > then
>> > try again. To search a file, click the Start button, and then click
>> > Search.".
>> >
>> > After clicking "OK" to close the message box, Firefox launchs and the
>> > link
>> > opens normally.
>>
>>
>> This is a problem with the windows browser registration.
>>
>> If you set your default browser to IE and then back to FF, that should fix
>> it.
>>
>> -D
>
> I just followed your advice but there is still this bug.
>
> Actually the strange thing is that it happens with Firefox, but not with IE.
> And it happens only with Pidgin, and not with other programs like Lotus
> Notes for example.
>
> The bad couple seems thus to be Pidgin/Firefox.
>

What is happening is that FF is either not telling Windows that it
successfully received the URL or a timeout has passed and Windows
hadn't yet received the request.

It is likely related to your FF configuration somehow (pidgin has no
idea which browser you're using, it just asks windows to open the URL
with the default handler) - you might try googling and/or reinstalling
FF(this isn't an uncommon problem).

The reason you may not see this with some other programs is that there
are several ways to launch URLs in Windows.  I suspect, however that
of you try to Start->Run->"http://www.pidgin.im" you'll see the same
behavior.

-D



More information about the Support mailing list