Trouble with Pidgin

James Fleming jaemz at alum.mit.edu
Sun Oct 18 09:46:00 EDT 2009


Hi there, I'm trying to use pidgin 2.6.1 with windows 7, using a VPN to 
connect to work.   When I follow the instructions they gave me at work, 
literally nothing happens.  I get no error messages about not being able 
to find a server, no error message about bad password, nothing.  But no 
buddies show up either, and I can't get any information about anything.

I turned on the debug window, and here's the output:


(09:41:46) *util:* Writing file prefs.xml to directory 
C:\Users\Jaemz\AppData\Roaming\.purple
(09:41:46) *util:* Writing file 
C:\Users\Jaemz\AppData\Roaming\.purple\prefs.xml
(09:41:51) *jabber:* Sending: <iq type='get' id='purpleee29376b' 
to='jaemz'><vCard xmlns='vcard-temp'/></iq>
*(09:41:51) g_log: file win32/libc_interface.c: line 398 
(wpurple_write): should not be reached
*(09:41:51) *connection:* Connection error on 042319D8 (reason: 0 
description: Lost connection with server: Bad file descriptor)
(09:41:51) *jabber:* Sending: <iq type='get' id='purpleee29376c' 
to='jaemz'><query xmlns='jabber:iq:last'/></iq>
*(09:41:51) g_log: file win32/libc_interface.c: line 398 
(wpurple_write): should not be reached
*(09:41:51) *account:* Disconnecting account 02117C98
(09:41:51) *connection:* Disconnecting connection 042319D8
(09:41:51) *connection:* Destroying connection 042319D8
(09:41:56) *util:* Writing file accounts.xml to directory 
C:\Users\Jaemz\AppData\Roaming\.purple
(09:41:56) *util:* Writing file 
C:\Users\Jaemz\AppData\Roaming\.purple\accounts.xml

To me it looks like the program is actually crashing on line 398 on this 
libc_interface.c!!  Do I need some sort of new libc redist?  Does pidgin 
not work with windows 7?

Thanks for any help you can give me, this is driving me nuts. 
-James



More information about the Support mailing list