No subject

David Chmelik dchmelik at hipplanet.com
Mon Jun 15 23:14:42 EDT 2009


Peace be with you,

    Over the years I have seen a pidgin bug sometimes.  Instructions for backtracing are only for a few GNU/Linux distros and do not say where to get debugging symbols otherwise.  It seems a bug exists with the display for default X setups, though I did export DISPLAY=0:0.0 and gdb reported a segmentation fault.  I tried debugging but it says 'no symbol tables' a lot of times, though it does mention libgstreamer.

Following is the display bug, which has been reported again this year, but I see no fix listed for.

----------------------------------------------------------------
$ pidgin

(pidgin:4199): Gdk-CRITICAL **: gdk_display_get_name: assertion `GDK_IS_DISPLAY (display)' failed
Pidgin 2.5.6

** (pidgin:4199): WARNING **: cannot open display: unset
----------------------------------------------------------------

It mainly happens when I run X/KDE as root and pidgin non-root.  Some people say not to run X as root, but I have used Unix/Linux 11 years and I am not going to: I would have to xterm login root most times, which is preposterous.  On LinuxQuestions someone said remove .Xauthority, but root always makes it.  I cannot figure out how I fixed this last time.  I am not on the mailing list but if you add a report to the bug database or want me to try anything, just write me back here or privately to my same user name as this e-address but at gmail, which I check more often.  Maybe within a couple weeks I will also check if the gmane group is this list.

--David


_____________________________________________________________
Find out what's HIP!
Visit Hip Planet for news, shopping, forums, chatrooms, free personal and classified ads and much more!
Get FREE E-MAIL! at HipPlanet now!

It's all waiting for you, at http://www.hipplanet.com



More information about the Support mailing list