Pidgin ignores DISPLAY variable.

Rogier Wolff R.E.Wolff at BitWizard.nl
Thu Jan 22 19:26:42 EST 2009


Hi,

I have a second X windows server running on my machine. It's :1.0 .

To run an xterm on that display I use either 

	xterm -display :1.0

or 
	setenv DISPLAY :1.0
	xterm &

Pidgin however doesn't seem to support the first method (no -display
option), and it more or less ignores the DISPLAY environment variable:

it mumbles: 

Xlib:  extension "RANDR" missing on display ":1.0".

and then displays on :0.0

As far as I know you need to go pretty extensive lengths before you
can get an X application to ignore the DISPLAY varibable. Who decided
that pidgin should always use :0.0 ?

I just googled for what RANDR is... the RandR extension is not
essential to pidgin. Maybe pidgin likes to be notified of resolution
changes, Fine. If not available, that should NOT be fatal. And even if
it is, then it should not ignore my DISPLAY setting and display
somewhere else.

(Think what would happen if I share a computer with someone with a
multi-keyboard/multi-screen setup and I'm the one on :1.0, and I start
pidgin. Then the guy on :0.0 will get all the hot IM's from my
girlfriend!)

	Roger. 

-- 
** R.E.Wolff at BitWizard.nl ** http://www.BitWizard.nl/ ** +31-15-2600998 **
**    Delftechpark 26 2628 XH  Delft, The Netherlands. KVK: 27239233    **
*-- BitWizard writes Linux device drivers for any device you may have! --*
Q: It doesn't work. A: Look buddy, doesn't work is an ambiguous statement. 
Does it sit on the couch all day? Is it unemployed? Please be specific! 
Define 'it' and what it isn't doing. --------- Adapted from lxrbot FAQ



More information about the Support mailing list