Pidgin 2.5.2 failed to connect

Daniel Atallah daniel.atallah at gmail.com
Tue Oct 21 10:43:55 EDT 2008


On Tue, Oct 21, 2008 at 10:40 AM, Stefan X <stefanxe at gmx.net> wrote:
> Hi Daniel!
> I double-checked but the checkbox you mentioned is NOT selected.
>
> Thanks!
>
> Daniel Atallah schrieb:
>> On Tue, Oct 21, 2008 at 9:13 AM, Stefan X <stefanxe at gmx.net> wrote:
>>> I was happy to tryout Pdigin 2.5.2 which should fix the ticket #1435
>>> ("server handshake failes due to cipher spec mismatch"). Unfortunately
>>> connecting to my Jabber account (ejabberd) through port 5222 (new TLS
>>> protocol) still fails. Connecting with old SSL to port 5223 is still
>>> possible. Here is the debug log when connection to port 5222:
>>>
>>>> ---
>>> (15:01:49) account: Connecting to account stefan at example.com/Home
>>> (15:01:49) connection: Connecting. gc = 03728510
>>> (15:01:49) dnsquery: Performing DNS lookup for jabber.example.com
>>> (15:01:49) dnsquery: IP resolved for jabber.example.com
>>> (15:01:49) proxy: Attempting connection to 84.19.xxx.yyy
>>> (15:01:49) proxy: Connecting to jabber.example.com:5222 with no proxy
>>> (15:01:49) proxy: Connection in progress
>>> (15:01:49) proxy: Connected to jabber.example.com:5222.
>>> (15:01:49) jabber: Sending: <?xml version='1.0' ?>
>>> (15:01:49) jabber: Sending: <stream:stream to='example.com'
>>> xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams'
>>> version='1.0'>
>>> (15:01:49) jabber: Recv (21): <?xml version='1.0'?>
>>> (15:01:50) jabber: Recv (365): <stream:stream xmlns='jabber:client'
>>> xmlns:stream='http://etherx.jabber.org/streams' id='287236560'
>>> from='example.com' version='1.0'
>>> xml:lang='en'><stream:features><mechanisms
>>> xmlns='urn:ietf:params:xml:ns:xmpp-sasl'><mechanism>DIGEST-MD5</mechanism><mechanism>PLAIN</mechanism></mechanisms><register
>>> xmlns='http://jabber.org/features/iq-register'/></stream:features>
>>> (15:01:50) account: Disconnecting account 00CD9708
>>> (15:01:50) connection: Disconnecting connection 03728510
>>> (15:01:50) jabber: XML parser error for JabberStream 036BBA00: Domain 1,
>>> code 5, level 3: Extra content at the end of the document
>>>
>>> (15:01:50) jabber: jabber_actions: have pep: NO
>>> (15:01:50) connection: Destroying connection 03728510
>>>> ---
>>> My ejabberd server tells me "Accepted connection".
>>>
>>> Any ideas what may be the cause of this problem?
>>
>> It looks like you have the "Create this new account on the server"
>> checkbox checked (it is trying to register a new account).  If you're
>> just trying to connect to an existing account, you shouldn't have that
>> checked.

Oops, I misread the debug output - the server was just telling you
that it supported registering.

-D



More information about the Support mailing list