Missing icons running as non-admin under Vista

Daniel Atallah daniel.atallah at gmail.com
Tue Oct 21 10:38:54 EDT 2008


2008/10/20  <hkclark at gmail.com>:
> Hi,
>
> I have found a few items talking about icons not appearing under Windows
> Vista (just an X appears instead):
>
> http://developer.pidgin.im/ticket/7041
> http://developer.pidgin.im/ticket/2539
>     (Note: I'm getting the missing icon issue, but not the crash with Help,
> About)
>
> If I right-click the Pidgin startup icon and select "Run as Administrator",
> it works.
>
> I have had this problem ever since Pidgin 2.4.0 (2.3.1 was the last version
> that worked).  I have tried every version since 2.4.0 and they all have the
> same issue (I have tried Pidgin versions 2.4.0, 2.4.1, 2.4.2, 2.5.1 and
> 2.5.2).  BUT, if I go back and re-install the GTK 2.12.1 that came with
> 2.3.1 and then run the newer Pidgin version install WITHOUT updating GTK, it
> works.
>
> I'm pretty sure the only other application that uses GTK on my machine is
> Wireshark and I have made sure it is NOT running.  I have tried running the
> Pidgin install right after reboots to make sure the file still wasn't it use
> for some mysterious reason, but to no avail.
>
> Any ideas who might be going on?

After talking with another user with a similar issue, it appears that
this caused by a stray "gdk-pixbuf.loaders" file in your user's
VirtualStore directory.

If you search your drive for files called "gdk-pixbuf.loaders", I bet
you'll find one in
c:\Users\<USERNAME>\AppData\Local\VirtualStore\Program Files\Common
Files\GTK\2.0\etc\gtk-2.0

You should be able to delete the
c:\Users\<USERNAME>\AppData\Local\VirtualStore\Program Files\Common
Files\GTK\2.0 directory and this problem should stop happening.

-D



More information about the Support mailing list