building on mac os

Michael Zech keldrin at
Tue Dec 23 09:19:53 EST 2008

hi there!

I am trying to build pidgin with the gtk2-aqua libs (they don't use  
x11 and so it's faster and prettier than the fink packages). But i run  
into some compiler problems:

bash-3.2$ make
make  all-recursive
Making all in libpurple
make  all-recursive
Making all in plugins
Making all in perl
if /bin/sh ../../../libtool --silent --tag=CC --mode=compile gcc - 
DHAVE_CONFIG_H -I. -I. -I../../..  -I../../.. -I../../../libpurple - 
I../../../libpurple -Wall  -DPURPLE_DISABLE_DEPRECATED - 
DGNT_DISABLE_DEPRECATED -D_REENTRANT -I/Users/michi/gtk/inst/include/ 
glib-2.0 -I/Users/michi/gtk/inst/lib/glib-2.0/include    -arch i386 - 
arch ppc -g -pipe -fno-common -DPERL_DARWIN -no-cpp-precomp -fno- 
strict-aliasing -Wdeclaration-after-statement -I/usr/local/include  -I/ 
System/Library/Perl/5.8.8/darwin-thread-multi-2level/CORE  -I/usr/ 
local/include -I/sw/include  -g -I/usr/local/include -arch i386 -MT  
perl.lo -MD -MP -MF ".deps/perl.Tpo" -c -o perl.lo perl.c; \
	then mv -f ".deps/perl.Tpo" ".deps/perl.Plo"; else rm -f ".deps/ 
perl.Tpo"; exit 1; fi
gcc-4.0: -E, -S, -save-temps and -M options are not allowed with  
multiple -arch flags
make[5]: *** [perl.lo] Error 1
make[4]: *** [all-recursive] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Ok, the message is clear: multiple arch doesn't work.. no problem for  
my mac is intel based. so i tried to export CFLAGS="-arch i368", i  
tried to add --with-arch-ppc=no to the configure options, i googled a  
lot, i tried to find out where ./configure detects the architecture.  
Well.. it didn't work.

So my question is simple: how can i tell the configure script which  
architecture to build and which one i don't want to have?

Thanks a lot,

More information about the Support mailing list