Help! Cannot compile pidgin

Christian Baer christian.baer at uni-dortmund.de
Fri Sep 21 08:02:33 EDT 2007


On Fri, Sep 21, 2007 at 15:18 +0800, tkdchen wrote:
 
> I cannot compile pidgin on FreeBSD 6.2. The following is the error
> messages:
> 
> ===>  Installing for avahi-0.6.14
> ===>   avahi-0.6.14 depends on executable in : pkg-config - found
> ===>   Generating temporary packing list
> ===>  Checking if net/avahi already installed
> ===>   avahi-0.6.14 is already installed
>       You may wish to ``make deinstall'' and install this port again
>       by ``make reinstall'' to upgrade it properly.
>       If you really wish to overwrite the old port of net/avahi
>       without deleting it first, set the variable "FORCE_PKG_REGISTER"
>       in your environment or the "make install" command line.
 
> Why this happend, and how to solve it? Thanks!

This is *not* a problem with Pidgin but with your FreeBSD installation. As
it seems, you already have avahi installed. Possibly the last installation
didn't work or was interrupted or you have updated the ports tree an there
is an older version installed. Do you have an older version of Pidgin
installed?

Go into the directory /usr/ports/net/avahi and in there do a
make deinstall clean distclean

That will remove all the stuff you may still have in there and deinstall
the port. After that you may want to do a 'pkgdb -F' (the directory
doesn't matter) in case you have a stale package database. Usually this
should not be required though.

Now you can go back into the pidgin directory and do a 'make config all'.

You may wish to take a look at these ports too for the future (all in
the /usr/ports/ports-mgmt/ directory:
-portupgrade
-pkg_cutleaves
-portsopt

Regards
Chris


More information about the Support mailing list