Help! Cannot compile pidgin

Kevin M Stange kevin at simguy.net
Fri Sep 21 04:20:11 EDT 2007


tkdchen wrote:
> Hi,
> 
> I cannot compile pidgin on FreeBSD 6.2. The following is the error messages:
> 
> ===>  Installing for avahi-0.6.14
> ===>   avahi-0.6.14 depends on executable in : pkg-config - found
> ===>   Generating temporary packing list
> ===>  Checking if net/avahi already installed
> ===>   avahi-0.6.14 is already installed
>       You may wish to ``make deinstall'' and install this port again
>       by ``make reinstall'' to upgrade it properly.
>       If you really wish to overwrite the old port of net/avahi
>       without deleting it first, set the variable "FORCE_PKG_REGISTER"
>       in your environment or the "make install" command line.
> *** Error code 1
> 
> Stop in /usr/ports/net/avahi.
> *** Error code 1
> 
> Why this happend, and how to solve it? Thanks!
> 

This is because your Pidgin port is trying to add a new version of
Avahi, but you already have an older one.  Ports wants to you clean the
old one out or force it to upgrade.  This isn't a pidgin issue, it's
just a quirk of ports.

Kevin

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 252 bytes
Desc: OpenPGP digital signature
Url : http://pidgin.im/pipermail/support/attachments/20070921/b3c11498/attachment.pgp 


More information about the Support mailing list