Packages required for Solaris 10

Robert D. Hawkins rhawkins at utampa.net
Thu Nov 22 00:46:18 EST 2007


Does anyone have a list of the packages that must be installed on Solaris 10 in order to compile and run Pidgin?  I am beating my head against the wall.  Configure completes apparently successfully and tells me to run make.  There are warnings in the config.log file that tell me that certain files were not found in my Config_Path.  These files do not exist on my machine.  I run make and it is still trying to add a -t option that the gcc compiler is apparently choking on.  I will add the config.log and the error output from the make command.  Any guidance would be greatly appreciated.

Rob
-------------- next part --------------
A non-text attachment was scrubbed...
Name: config.log
Type: text/x-log
Size: 186946 bytes
Desc: not available
Url : http://pidgin.im/pipermail/support/attachments/20071122/550ede1a/attachment-0002.bin 
-------------- next part --------------
Package x11 was not found in the pkg-config search path.
Perhaps you should add the directory containing `x11.pc'
to the PKG_CONFIG_PATH environment variable
No package 'x11' found
Package gtkspell-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtkspell-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtkspell-2.0' found
Package libebook-1.2 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libebook-1.2.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libebook-1.2' found
Package libebook-1.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libebook-1.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libebook-1.0' found
Package sqlite3 was not found in the pkg-config search path.
Perhaps you should add the directory containing `sqlite3.pc'
to the PKG_CONFIG_PATH environment variable
No package 'sqlite3' found
Package gstreamer-0.10 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gstreamer-0.10.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gstreamer-0.10' found
Package meanwhile was not found in the pkg-config search path.
Perhaps you should add the directory containing `meanwhile.pc'
to the PKG_CONFIG_PATH environment variable
No package 'meanwhile' found
Package avahi-client was not found in the pkg-config search path.
Perhaps you should add the directory containing `avahi-client.pc'
to the PKG_CONFIG_PATH environment variable
No package 'avahi-client' found
Package avahi-compat-howl was not found in the pkg-config search path.
Perhaps you should add the directory containing `avahi-compat-howl.pc'
to the PKG_CONFIG_PATH environment variable
No package 'avahi-compat-howl' found
Package howl was not found in the pkg-config search path.
Perhaps you should add the directory containing `howl.pc'
to the PKG_CONFIG_PATH environment variable
No package 'howl' found
Package silcclient was not found in the pkg-config search path.
Perhaps you should add the directory containing `silcclient.pc'
to the PKG_CONFIG_PATH environment variable
No package 'silcclient' found
Package silcclient was not found in the pkg-config search path.
Perhaps you should add the directory containing `silcclient.pc'
to the PKG_CONFIG_PATH environment variable
No package 'silcclient' found
Package silc was not found in the pkg-config search path.
Perhaps you should add the directory containing `silc.pc'
to the PKG_CONFIG_PATH environment variable
No package 'silc' found
Package libgadu was not found in the pkg-config search path.
Perhaps you should add the directory containing `libgadu.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libgadu' found
Package dbus-1 was not found in the pkg-config search path.
Perhaps you should add the directory containing `dbus-1.pc'
to the PKG_CONFIG_PATH environment variable
No package 'dbus-1' found
configure: WARNING: EXTERN.h: present but cannot be compiled
configure: WARNING: EXTERN.h:     check for missing prerequisite headers?
configure: WARNING: EXTERN.h: see the Autoconf documentation
configure: WARNING: EXTERN.h:     section "Present But Cannot Be Compiled"
configure: WARNING: EXTERN.h: proceeding with the preprocessor's result
configure: WARNING: EXTERN.h: in the future, the compiler will take precedence
configure: WARNING:     ## ------------------------------ ##
configure: WARNING:     ## Report this to devel at pidgin.im ##
configure: WARNING:     ## ------------------------------ ##
Package check was not found in the pkg-config search path.
Perhaps you should add the directory containing `check.pc'
to the PKG_CONFIG_PATH environment variable
No package 'check' found
configure: WARNING: *** Doxygen not found, docs will not be available
config.status: WARNING:  pidgin/pidgin.pc.in seems to ignore the --datarootdir setting
config.status: WARNING:  pidgin/pidgin-uninstalled.pc.in seems to ignore the --datarootdir setting
config.status: WARNING:  libpurple/purple.pc.in seems to ignore the --datarootdir setting
config.status: WARNING:  libpurple/purple-uninstalled.pc.in seems to ignore the --datarootdir setting
config.status: WARNING:  finch/finch.pc.in seems to ignore the --datarootdir setting
-------------- next part --------------
A non-text attachment was scrubbed...
Name: configure.log
Type: text/x-log
Size: 22291 bytes
Desc: not available
Url : http://pidgin.im/pipermail/support/attachments/20071122/550ede1a/attachment-0003.bin 


More information about the Support mailing list