Adding JSON library to libpurple dependencies

Mark Doliner mark at kingant.net
Wed Jan 23 02:16:47 EST 2013


On Sat, Jan 19, 2013 at 12:41 AM, Kevin Stange <kstange at pidgin.im> wrote:
> On 01/19/2013 02:30 AM, Mark Doliner wrote:
>> I made a table:
>> https://developer.pidgin.im/wiki/Dependencies
>>
>> On Mon, Jan 14, 2013 at 6:03 PM, Elliott Sales de Andrade
>> <qulogic at pidgin.im> wrote:
>>> On Mon, Jan 14, 2013 at 3:18 AM, Mark Doliner <mark at kingant.net> wrote:
>>>> Based on this, I went ahead and changed our requirement to 0.14.0 in
>>>> configure.ac in main.
>>>
>>> FYI, json-glib 0.14.0 also depends on GLib 2.26, so we could
>>> theoretically bump our GLib requirements as well.
>>
>> We'll drop support for (Pidgin 3.0.0 and higher only):
>> - RHEL6 and Scientific Linux 6 (only has glib2 2.22.5)
>
> I think this is the biggest worry, because there's no newer release
> available.  However, RHEL will probably do all the backporting work if
> they need to to make 2.x keep going for the rest of the 6 series,
> regardless of whether 3.0.0 builds on it.  I think we can safely
> disregard it.  RHEL 7 will certainly have a higher glib2, though it will
> probably be released in 2014.

Eh, well let's leave glib at 2.20 for now, since we don't gain much by
bumping it up.  That leaves open the possibility of someone building
3.0.0 on RHEL6 by removing json-glib.



More information about the Devel mailing list