Adding JSON library to libpurple dependencies

Mark Doliner mark at
Sat Jan 19 03:30:05 EST 2013

I made a table:

On Mon, Jan 14, 2013 at 6:03 PM, Elliott Sales de Andrade
<qulogic at> wrote:
> On Mon, Jan 14, 2013 at 3:18 AM, Mark Doliner <mark at> wrote:
>> Based on this, I went ahead and changed our requirement to 0.14.0 in
>> in main.
> FYI, json-glib 0.14.0 also depends on GLib 2.26, so we could
> theoretically bump our GLib requirements as well.

We'll drop support for (Pidgin 3.0.0 and higher only):
- RHEL6 and Scientific Linux 6 (only has glib2 2.22.5)
- Debian Stable (glib 2.24)
- Ubuntu 10.04 Lucid Lynx (glib 2.24.1)

This sounds fine to me.  Anyone object?

> Also, it depends on automake 1.11, so maybe we'd want to bump that as
> well. I think the only thing that gains us is silent-rules, but we
> already optionally use it anyway.

Looks like everybody has automake 1.11, so I think this is fine.

More information about the Devel mailing list