Adding JSON library to libpurple dependencies

Peter Lawler bleeter at gmail.com
Mon Jan 14 22:47:19 EST 2013


On 15/01/13 13:03, Elliott Sales de Andrade wrote:
> On Mon, Jan 14, 2013 at 3:18 AM, Mark Doliner <mark at kingant.net> wrote:
>> Based on this, I went ahead and changed our requirement to 0.14.0 in
>> configure.ac in main.
>>
> FYI, json-glib 0.14.0 also depends on GLib 2.26, so we could
> theoretically bump our GLib requirements as well.
>
> Also, it depends on automake 1.11, so maybe we'd want to bump that as
> well. I think the only thing that gains us is silent-rules, but we
> already optionally use it anyway.
>
I'd certainly agree with an idea that a Major release should cause 
re-evaluation of every core dependency and looking at making what was 
formerly optional a requirement.

I say this without any knowledge of what's been looked in to recently, 
and mean no offence if this is what's already being done :)

Pete.



More information about the Devel mailing list