Adding JSON library to libpurple dependencies

Peter Lawler bleeter at gmail.com
Mon Jan 14 06:23:25 EST 2013


On 14/01/13 19:42, Kevin Stange wrote:
> On 01/14/2013 02:18 AM, Mark Doliner wrote:
>> json-glib seems to be missing from Scientific Linux, which I find
>> confusing, but I'm fine ignoring this for now.
> I checked and it's not in EPEL either.  Most likely, if it comes to be
> required by a package, it will be added in the next EL update along with
> that package update.  This probably means EL7, as I expect that Red Hat
> will not change EL6 or EL5 from the 2.x series of libpurple unless they
> opt to ship it separately as libpurple3.


For giggles, I took a quick look...

it'd be a bit ugly... 'missing' from my 'standard' CentOS 6.3 ... so 
I've had problems building json-glib probably because I tried taking a 
cheap route with F17 source RPMs...

For gobject-introspection I installed gnome-common, libffi-devel but 
still needed at least cairo-gobject-devel and I then decided listening 
to Peter Kenny read Iain M Banks was far preferable.

I'm sure it'll just be easier to tell CERN et al to build their own damn 
json-glib and put it in and be done with it. With any luck, they'll tell 
us to build our own damned Higgs-Boson detector....

Pete.



More information about the Devel mailing list