Adding JSON library to libpurple dependencies

Mark Doliner mark at kingant.net
Mon Jan 14 03:18:13 EST 2013


Thanks for tackling this, Tomasz.  Sorry you haven't gotten a lot of
feedback on it.  And thanks for the recommendation, Eion.  It's
helpful to know that you've used it and are happy with it.

On Thu, Sep 27, 2012 at 1:11 PM, Tomasz Wasilczyk
<tomkiewicz.groups at gmail.com> wrote:
> One little concern: which version should I require? There is 0.14 with
> JSONPath support, but not available in stock repositories of older
> distros (openSUSE 11.4). I suppose, we cannot include JSONPath related
> source code from upstream for fallback when using with json-glib 0.12?

json-glib seems to be missing from Scientific Linux, which I find
confusing, but I'm fine ignoring this for now.  Aside from that it
looks like only Debian Stable doesn't have json-glib 0.14, but they're
still on Pidgin 2.7.3 so I don't think we need to worry about them
upgrading to 3.0.0 yet.

Here's what I found:
Ubuntu 12.04 LTS (Precise Pangolin) has 0.14.2
Ubuntu 12.10 (Quantal Quetzal) has 0.15.2
Debian Stable (Squeeze) has 0.10.2
Debian Testing (Wheezy) has 0.14.2
Debian Unstable (Sid) has "0.14.2-1 and others" (whatever that means)
Fedora 17 has 0.14.2
Fedora 18 has 0.15.2

Based on this, I went ahead and changed our requirement to 0.14.0 in
configure.ac in main.

> But: do we support old distros with 3.0.0 tree?

We certainly care less about backward compatibility with 3.0.0 than
with 2.x.y.  Realistically I'm not sure any existing distro versions
will upgrade to 3.0.0 themselves (rather, they'll upgrade to 3.0.0 in
their next major release).  It's nice for us to maintain compatibility
when possible, in case users want to compile themselves, but this
should not be our highest priority.



More information about the Devel mailing list